CVE-2004-2303 Affecting mtools package, versions <3.9.9


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.63% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-MTOOLS-5689608
  • published31 Dec 2004
  • disclosed31 Dec 2004

Introduced: 31 Dec 2004

CVE-2004-2303  (opens in a new tab)

How to fix?

Upgrade Debian:13 mtools to version 3.9.9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mtools package and not the mtools package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

MTools Mformat before 3.9.9, when installed setuid root, creates files with world-readable and world-writable permissions, which allows local users to read and overwrite files.

CVSS Base Scores

version 3.1