Integer Overflow or Wraparound Affecting ocaml package, versions <5.2.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-OCAML-15805637
  • published29 Mar 2026
  • disclosed27 Mar 2026

Introduced: 27 Mar 2026

CVE-2026-34353  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:13 ocaml to version 5.2.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ocaml package and not the ocaml package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

In OCaml through 4.14.3, Bigarray.reshape allows an integer overflow, and resultant reading of arbitrary memory, when untrusted data is processed.

CVSS Base Scores

version 3.1