Out-of-bounds Write Affecting olm package, versions <3.2.3~dfsg-3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.26% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-OLM-5690741
  • published17 Jun 2021
  • disclosed16 Jun 2021

Introduced: 16 Jun 2021

CVE-2021-34813  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:13 olm to version 3.2.3~dfsg-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream olm package and not the olm package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Matrix libolm before 3.2.3 allows a malicious Matrix homeserver to crash a client (while it is attempting to retrieve an Olm encrypted room key backup from the homeserver) because olm_pk_decrypt has a stack-based buffer overflow. Remote code execution might be possible for some nonstandard build configurations.

CVSS Base Scores

version 3.1