Arbitrary Command Injection Affecting pglogical package, versions <2.3.3-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.46% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PGLOGICAL-5692524
  • published18 May 2021
  • disclosed1 Jun 2021

Introduced: 18 May 2021

CVE-2021-3515  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:13 pglogical to version 2.3.3-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pglogical package and not the pglogical package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().

CVSS Base Scores

version 3.1