Incorrect Authorization Affecting php-twig package, versions <3.27.0-0+deb13u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.4% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PHPTWIG-16896311
  • published28 May 2026
  • disclosed14 Jul 2026

Introduced: 28 May 2026

CVE-2026-47732  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Debian:13 php-twig to version 3.27.0-0+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-twig package and not the php-twig package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Twig is a template language for PHP. Prior to 3.26.0, several Twig language constructs trigger PHP string coercion on a Stringable operand without consulting SecurityPolicy::checkMethodAllowed(), allowing a sandboxed template author to invoke __toString() on objects reachable in the render context through conditional expressions, comparison operators, tests, template-loading tags, dynamic attribute names, spread arguments, the do tag, and the .. range operator. This issue is fixed in version 3.26.0.

CVSS Base Scores

version 3.1