Protection Mechanism Failure Affecting php-twig package, versions <3.27.0-0+deb13u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.48% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PHPTWIG-17090539
  • published29 May 2026
  • disclosed14 Jul 2026

Introduced: 29 May 2026

CVE-2026-48805  (opens in a new tab)
CWE-693  (opens in a new tab)

How to fix?

Upgrade Debian:13 php-twig to version 3.27.0-0+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-twig package and not the php-twig package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Twig is a template language for PHP. Prior to 3.27.0, deprecated internal wrappers in src/Resources/core.php do not forward the current sandbox state to CoreExtension::checkArrow(), arraySome(), and arrayEvery(), allowing legacy calls such as twig_array_some(), twig_array_every(), and twig_check_arrow_in_sandbox() to bypass sandbox callable restrictions. This issue is fixed in version 3.27.0.

CVSS Base Scores

version 3.1