Buffer Over-read Affecting pngcheck package, versions <3.0.2-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.36% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PNGCHECK-5692955
  • published26 Aug 2022
  • disclosed23 Aug 2022

Introduced: 23 Aug 2022

CVE-2020-35511  (opens in a new tab)
CWE-126  (opens in a new tab)

How to fix?

Upgrade Debian:13 pngcheck to version 3.0.2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pngcheck package and not the pngcheck package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A global buffer overflow was discovered in pngcheck function in pngcheck-2.4.0(5 patches applied) via a crafted png file.

CVSS Base Scores

version 3.1