SQL Injection Affecting postfixadmin package, versions <2.3.5-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.88% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-POSTFIXADMIN-5693115
  • published2 Apr 2014
  • disclosed2 Apr 2014

Introduced: 2 Apr 2014

CVE-2014-2655  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:13 postfixadmin to version 2.3.5-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postfixadmin package and not the postfixadmin package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

SQL injection vulnerability in the gen_show_status function in functions.inc.php in Postfix Admin (aka postfixadmin) before 2.3.7 allows remote authenticated users to execute arbitrary SQL commands via a new alias.

CVSS Base Scores

version 3.1