CVE-2013-2132 Affecting pymongo package, versions <2.5.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.11% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PYMONGO-5693280
  • published15 Aug 2013
  • disclosed15 Aug 2013

Introduced: 15 Aug 2013

CVE-2013-2132  (opens in a new tab)

How to fix?

Upgrade Debian:13 pymongo to version 2.5.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pymongo package and not the pymongo package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

bson/_cbsonmodule.c in the mongo-python-driver (aka. pymongo) before 2.5.2, as used in MongoDB, allows context-dependent attackers to cause a denial of service (NULL pointer dereference and crash) via vectors related to decoding of an "invalid DBRef."

CVSS Base Scores

version 3.1