Improper Input Validation Affecting python-cryptography package, versions <1.5.3-1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High

    Threat Intelligence

    EPSS 0.58% (78th percentile)
Expand this section
NVD
7.5 high
Expand this section
Red Hat
4.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN13-PYTHONCRYPTOGRAPHY-5693315
  • published 27 Mar 2017
  • disclosed 27 Mar 2017

How to fix?

Upgrade Debian:13 python-cryptography to version 1.5.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-cryptography package and not the python-cryptography package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

HKDF in cryptography before 1.5.2 returns an empty byte-string if used with a length less than algorithm.digest_size.