Improper Check for Unusual or Exceptional Conditions Affecting python-cryptography package, versions <38.0.4-3


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.07% (28th percentile)
Expand this section
NVD
6.5 medium
Expand this section
SUSE
4 medium
Expand this section
Red Hat
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN13-PYTHONCRYPTOGRAPHY-5693465
  • published 9 Feb 2023
  • disclosed 7 Feb 2023

How to fix?

Upgrade Debian:13 python-cryptography to version 38.0.4-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-cryptography package and not the python-cryptography package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In affected versions Cipher.update_into would accept Python objects which implement the buffer protocol, but provide only immutable buffers. This would allow immutable objects (such as bytes) to be mutated, thus violating fundamental rules of Python and resulting in corrupted output. This now correctly raises an exception. This issue has been present since update_into was originally introduced in cryptography 1.8.