Arbitrary Code Injection Affecting python-uvicorn package, versions <0.13.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.39% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PYTHONUVICORN-5693702
  • published30 Aug 2020
  • disclosed27 Jul 2020

Introduced: 27 Jul 2020

CVE-2020-7695  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Debian:13 python-uvicorn to version 0.13.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-uvicorn package and not the python-uvicorn package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Uvicorn before 0.11.7 is vulnerable to HTTP response splitting. CRLF sequences are not escaped in the value of HTTP headers. Attackers can exploit this to add arbitrary headers to HTTP responses, or even return an arbitrary response body, whenever crafted input is used to construct HTTP headers.

CVSS Base Scores

version 3.1