Access Restriction Bypass Affecting radsecproxy package, versions <1.6.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.5% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-RADSECPROXY-5694173
  • published20 Nov 2012
  • disclosed20 Nov 2012

Introduced: 20 Nov 2012

CVE-2012-4566  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:13 radsecproxy to version 1.6.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream radsecproxy package and not the radsecproxy package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The DTLS support in radsecproxy before 1.6.2 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients, a different vulnerability than CVE-2012-4523.

CVSS Base Scores

version 3.1