Cross-site Scripting (XSS) Affecting request-tracker5 package, versions <5.0.7+dfsg-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.33% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-REQUESTTRACKER5-9904168
  • published30 Apr 2025
  • disclosed28 May 2025

Introduced: 30 Apr 2025

CVE-2025-30087  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:13 request-tracker5 to version 5.0.7+dfsg-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream request-tracker5 package and not the request-tracker5 package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Best Practical RT (Request Tracker) 4.4 through 4.4.7 and 5.0 through 5.0.7 allows XSS via injection of crafted parameters in a search URL.

CVSS Base Scores

version 3.1