CVE-2023-39914 Affecting rust-bcder package, versions <0.7.3-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.7% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-RUSTBCDER-5905021
  • published19 Sept 2023
  • disclosed13 Sept 2023

Introduced: 13 Sep 2023

CVE-2023-39914  (opens in a new tab)

How to fix?

Upgrade Debian:13 rust-bcder to version 0.7.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-bcder package and not the rust-bcder package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

NLnet Labs' bcder library up to and including version 0.7.2 panics while decoding certain invalid input data rather than rejecting the data with an error. This can affect both the actual decoding stage as well as accessing content of types that utilized delayed decoding.

CVSS Base Scores

version 3.1