Cryptographic Issues Affecting shibboleth-sp package, versions <3.0.2+dfsg1-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.54% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-SHIBBOLETHSP-5695723
  • published29 Sept 2009
  • disclosed29 Sept 2009

Introduced: 29 Sep 2009

CVE-2009-3474  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:13 shibboleth-sp to version 3.0.2+dfsg1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shibboleth-sp package and not the shibboleth-sp package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

CVSS Base Scores

version 3.1