Improper Input Validation Affecting spice-gtk package, versions <0.35-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.25% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-SPICEGTK-5695248
  • published14 Mar 2018
  • disclosed14 Mar 2018

Introduced: 14 Mar 2018

CVE-2017-12194  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

Upgrade Debian:13 spice-gtk to version 0.35-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spice-gtk package and not the spice-gtk package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.