Arbitrary Command Injection Affecting terminology package, versions <0.7.0-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.12% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-TERMINOLOGY-5696179
  • published23 Jan 2017
  • disclosed23 Jan 2017

Introduced: 23 Jan 2017

CVE-2015-8971  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:13 terminology to version 0.7.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream terminology package and not the terminology package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Terminology 0.7.0 allows remote attackers to execute arbitrary commands via escape sequences that modify the window title and then are written to the terminal, a similar issue to CVE-2003-0063.

CVSS Base Scores

version 3.1