Improper Certificate Validation Affecting tigervnc package, versions <1.10.1+dfsg-9


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.06% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-TIGERVNC-5697141
  • published27 Sept 2020
  • disclosed27 Sept 2020

Introduced: 27 Sep 2020

CVE-2020-26117  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Debian:13 tigervnc to version 1.10.1+dfsg-9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc package and not the tigervnc package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

In rfb/CSecurityTLS.cxx and rfb/CSecurityTLS.java in TigerVNC before 1.11.0, viewers mishandle TLS certificate exceptions. They store the certificates as authorities, meaning that the owner of a certificate could impersonate any server after a client had added an exception.

CVSS Base Scores

version 3.1