Embedded Malicious Code Affecting xz-utils package, versions <5.6.1+really5.4.5-1


0.0
critical
0
10

Snyk CVSS

    Attack Complexity Low
    Scope Changed
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    Social Trends Trending on Twitter
    Exploit Maturity Mature
    EPSS 13.34% (96th percentile)
Expand this section
NVD
10 critical
Expand this section
Red Hat
10 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN13-XZUTILS-6514282
  • published 30 Mar 2024
  • disclosed 29 Mar 2024

How to fix?

Upgrade Debian:13 xz-utils to version 5.6.1+really5.4.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xz-utils package and not the xz-utils package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Malicious code was discovered in the upstream tarballs of xz, starting with version 5.6.0. Through a series of complex obfuscations, the liblzma build process extracts a prebuilt object file from a disguised test file existing in the source code, which is then used to modify specific functions in the liblzma code. This results in a modified liblzma library that can be used by any software linked against this library, intercepting and modifying the data interaction with this library.

References