OS Command Injection Affecting yaws package, versions <2.0.8+dfsg-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
17.37% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-YAWS-5701891
  • published8 Sept 2020
  • disclosed9 Sept 2020

Introduced: 8 Sep 2020

CVE-2020-24916  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:13 yaws to version 2.0.8+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream yaws package and not the yaws package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

CVSS Base Scores

version 3.1