Arbitrary Command Injection Affecting celery package, versions <5.2.3-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.6% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-CELERY-11737317
  • published10 Aug 2025
  • disclosed29 Dec 2021

Introduced: 29 Dec 2021

CVE-2021-23727  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:14 celery to version 5.2.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream celery package and not the celery package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.

CVSS Base Scores

version 3.1