Out-of-bounds Write Affecting cimg package, versions <2.8.4+dfsg-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.75% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-CIMG-11739465
  • published10 Aug 2025
  • disclosed31 Jul 2019

Introduced: 31 Jul 2019

CVE-2019-13568  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 cimg to version 2.8.4+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cimg package and not the cimg package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

CImg through 2.6.7 has a heap-based buffer overflow in _load_bmp in CImg.h because of erroneous memory allocation for a malformed BMP image.