Improper Privilege Management Affecting e17 package, versions <0.25.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
6.01% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-E17-11740918
  • published10 Aug 2025
  • disclosed25 Dec 2022

Introduced: 25 Dec 2022

CVE-2022-37706  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade Debian:14 e17 to version 0.25.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream e17 package and not the e17 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

enlightenment_sys in Enlightenment before 0.25.4 allows local users to gain privileges because it is setuid root, and the system library function mishandles pathnames that begin with a /dev/.. substring.

CVSS Base Scores

version 3.1