Out-of-bounds Read Affecting e2fsprogs package, versions <1.46.6~rc1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.47% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-E2FSPROGS-11741015
  • published10 Aug 2025
  • disclosed14 Apr 2022

Introduced: 14 Apr 2022

CVE-2022-1304  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 e2fsprogs to version 1.46.6~rc1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream e2fsprogs package and not the e2fsprogs package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An out-of-bounds read/write vulnerability was found in e2fsprogs 1.46.5. This issue leads to a segmentation fault and possibly arbitrary code execution via a specially crafted filesystem.

CVSS Base Scores

version 3.1