Improper Certificate Validation Affecting evolution-ews package, versions <3.30.5-1.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.99% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-EVOLUTIONEWS-11741271
  • published10 Aug 2025
  • disclosed1 Aug 2019

Introduced: 1 Aug 2019

CVE-2019-3890  (opens in a new tab)
CWE-295  (opens in a new tab)
CWE-296  (opens in a new tab)

How to fix?

Upgrade Debian:14 evolution-ews to version 3.30.5-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream evolution-ews package and not the evolution-ews package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

It was discovered evolution-ews before 3.31.3 does not check the validity of SSL certificates. An attacker could abuse this flaw to get confidential information by tricking the user into connecting to a fake server without the user noticing the difference.