Integer Overflow or Wraparound Affecting exempi package, versions <2.6.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.95% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-EXEMPI-11741183
  • published10 Aug 2025
  • disclosed1 Sept 2021

Introduced: 1 Sep 2021

CVE-2021-36058  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 exempi to version 2.6.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream exempi package and not the exempi package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

XMP Toolkit SDK version 2020.1 (and earlier) is affected by an Integer Overflow vulnerability potentially resulting in application-level denial of service in the context of the current user. Exploitation requires user interaction in that a victim must open a crafted file.

CVSS Base Scores

version 3.1