Out-of-bounds Read Affecting f2fs-tools package, versions <1.14.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.5% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-F2FSTOOLS-11741531
  • published10 Aug 2025
  • disclosed15 Oct 2020

Introduced: 15 Oct 2020

CVE-2020-6104  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 f2fs-tools to version 1.14.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream f2fs-tools package and not the f2fs-tools package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An exploitable information disclosure vulnerability exists in the get_dnode_of_data functionality of F2fs-Tools F2fs.Fsck 1.13. A specially crafted f2fs filesystem can cause information disclosure resulting in a information disclosure. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1