Integer Overflow or Wraparound Affecting firebird4.0 package, versions <4.0.7.3271.ds6-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.13% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-FIREBIRD40-16100436
  • published18 Apr 2026
  • disclosed17 Apr 2026

Introduced: 17 Apr 2026

CVE-2026-28214  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-835  (opens in a new tab)

How to fix?

Upgrade Debian:14 firebird4.0 to version 4.0.7.3271.ds6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird4.0 package and not the firebird4.0 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, the ClumpletReader::getClumpletSize() function can overflow the totalLength value when parsing a Wide type clumplet, causing an infinite loop. An authenticated user with INSERT privileges on any table can exploit this via a crafted Batch Parameter Block to cause a denial of service against the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.

CVSS Base Scores

version 3.1