Directory Traversal Affecting flightcrew package, versions <0.7.2+dfsg-14


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.63% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-FLIGHTCREW-11743206
  • published10 Aug 2025
  • disclosed4 Jul 2019

Introduced: 4 Jul 2019

CVE-2019-13241  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:14 flightcrew to version 0.7.2+dfsg-14 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream flightcrew package and not the flightcrew package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

FlightCrew v0.9.2 and older are vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

CVSS Base Scores

version 3.1