Out-of-bounds Write Affecting gfs2-utils package, versions <3.6.1-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.13% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GFS2UTILS-19518390
  • published4 Sept 2026
  • disclosed3 Sept 2026

Introduced: 3 Sep 2026

CVE-2026-71221  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 gfs2-utils to version 3.6.1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gfs2-utils package and not the gfs2-utils package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A stack out-of-bounds write vulnerability was found in gfs2-utils. In savemeta, the height value from on-disk inode metadata is used as a loop bound without bounds checking, causing a stack buffer overflow that may lead to arbitrary code execution when processing crafted GFS2 filesystem images.

CVSS Base Scores

version 3.1