Out-of-bounds Read Affecting ghostscript package, versions <10.08.0~dfsg-1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GHOSTSCRIPT-22083438
  • published31 Oct 2026
  • disclosed30 Oct 2026

Introduced: 30 Oct 2026

NewCVE-2026-112922  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 ghostscript to version 10.08.0~dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript package and not the ghostscript package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in Ghostscript. A remote attacker could exploit this vulnerability by enticing a user to process a specially crafted PDF or PostScript document containing malicious mesh shading data. Due to improper bounds validation during the processing of indexed color values, Ghostscript triggers an out-of-bounds memory read. Successful exploitation can lead to a Denial of Service (DoS) through an application crash or result in limited information disclosure.

CVSS Base Scores

version 3.1