Out-of-Bounds Affecting giflib package, versions <5.1.4-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.1% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GIFLIB-11743881
  • published10 Aug 2025
  • disclosed21 Apr 2016

Introduced: 21 Apr 2016

CVE-2016-3977  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:14 giflib to version 5.1.4-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Heap-based buffer overflow in util/gif2rgb.c in gif2rgb in giflib 5.1.2 allows remote attackers to cause a denial of service (application crash) via the background color index in a GIF file.

CVSS Base Scores

version 3.1