Link Following Affecting gnome-autoar package, versions <0.2.4-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.65% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GNOMEAUTOAR-11744237
  • published10 Aug 2025
  • disclosed5 Feb 2021

Introduced: 5 Feb 2021

CVE-2020-36241  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Debian:14 gnome-autoar to version 0.2.4-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-autoar package and not the gnome-autoar package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

autoar-extractor.c in GNOME gnome-autoar through 0.2.4, as used by GNOME Shell, Nautilus, and other software, allows Directory Traversal during extraction because it lacks a check of whether a file's parent is a symlink to a directory outside of the intended extraction location.

CVSS Base Scores

version 3.1