CVE-2021-4235 Affecting golang-yaml.v2 package, versions <2.2.8-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.43% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GOLANGYAMLV2-11744593
  • published10 Aug 2025
  • disclosed27 Dec 2022

Introduced: 27 Dec 2022

CVE-2021-4235  (opens in a new tab)

How to fix?

Upgrade Debian:14 golang-yaml.v2 to version 2.2.8-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-yaml.v2 package and not the golang-yaml.v2 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Due to unbounded alias chasing, a maliciously crafted YAML file can cause the system to consume significant system resources. If parsing user input, this may be used as a denial of service vector.

CVSS Base Scores

version 3.1