Use of Externally-Controlled Format String Affecting graphviz package, versions <2.38.0-7


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.57% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GRAPHVIZ-11744892
  • published10 Aug 2025
  • disclosed3 Dec 2014

Introduced: 3 Dec 2014

CVE-2014-9157  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Debian:14 graphviz to version 2.38.0-7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream graphviz package and not the graphviz package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Format string vulnerability in the yyerror function in lib/cgraph/scan.l in Graphviz allows remote attackers to have unspecified impact via format string specifiers in unknown vectors, which are not properly handled in an error string.

CVSS Base Scores

version 3.1