Out-of-bounds Write Affecting gss-ntlmssp package, versions <1.2.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.94% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GSSNTLMSSP-11745043
  • published10 Aug 2025
  • disclosed14 Feb 2023

Introduced: 14 Feb 2023

CVE-2023-25564  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 gss-ntlmssp to version 1.2.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gss-ntlmssp package and not the gss-ntlmssp package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, memory corruption can be triggered when decoding UTF16 strings. The variable outlen was not initialized and could cause writing a zero to an arbitrary place in memory if ntlm_str_convert() were to fail, which would leave outlen uninitialized. This can lead to a denial of service if the write hits unmapped memory or randomly corrupts a byte in the application memory space. This vulnerability can trigger an out-of-bounds write, leading to memory corruption. This vulnerability can be triggered via the main gss_accept_sec_context entry point. This issue is fixed in version 1.2.0.

CVSS Base Scores

version 3.1