Out-of-bounds Read Affecting gss-ntlmssp package, versions <1.2.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.1% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GSSNTLMSSP-11745057
  • published10 Aug 2025
  • disclosed14 Feb 2023

Introduced: 14 Feb 2023

CVE-2023-25567  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 gss-ntlmssp to version 1.2.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gss-ntlmssp package and not the gss-ntlmssp package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the av_pair is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main gss_accept_sec_context entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.

CVSS Base Scores

version 3.1