Integer Overflow or Wraparound Affecting gst-plugins-bad1.0 package, versions <1.28.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.4% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GSTPLUGINSBAD10-22083480
  • published31 Oct 2026
  • disclosed30 Oct 2026

Introduced: 30 Oct 2026

NewCVE-2026-119729  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 gst-plugins-bad1.0 to version 1.28.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-bad1.0 package and not the gst-plugins-bad1.0 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in GStreamer. An integer overflow vulnerability in the AV1 LEB128 variable-length integer parser allows a remote attacker to cause a crash in applications that process AV1 media content. By crafting a malformed AV1 bitstream containing an invalid LEB128-encoded value, an attacker can cause integer overflow in the parser, resulting in incorrect length values being used during stream processing, which can lead to a denial of service.

CVSS Base Scores

version 3.1