Range Error Affecting gtk-vnc package, versions <0.6.0-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.32% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GTKVNC-11745331
  • published10 Aug 2025
  • disclosed28 Feb 2017

Introduced: 28 Feb 2017

CVE-2017-5884  (opens in a new tab)
CWE-118  (opens in a new tab)

How to fix?

Upgrade Debian:14 gtk-vnc to version 0.6.0-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gtk-vnc package and not the gtk-vnc package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

gtk-vnc before 0.7.0 does not properly check boundaries of subrectangle-containing tiles, which allows remote servers to execute arbitrary code via the src x, y coordinates in a crafted (1) rre, (2) hextile, or (3) copyrect tile.