Buffer Overflow Affecting guestfs-tools package, versions <1.48.3-4


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.97% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GUESTFSTOOLS-11745229
  • published10 Aug 2025
  • disclosed12 Jul 2022

Introduced: 12 Jul 2022

CVE-2022-2211  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Debian:14 guestfs-tools to version 1.48.3-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream guestfs-tools package and not the guestfs-tools package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A vulnerability was found in libguestfs. This issue occurs while calculating the greatest possible number of matching keys in the get_keys() function. This flaw leads to a denial of service, either by mistake or malicious actor.

CVSS Base Scores

version 3.1