Inadequate Encryption Strength Affecting haskell-aeson package, versions <2.0.3.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.83% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-HASKELLAESON-11745538
  • published10 Aug 2025
  • disclosed10 Oct 2022

Introduced: 10 Oct 2022

CVE-2022-3433  (opens in a new tab)
CWE-326  (opens in a new tab)

How to fix?

Upgrade Debian:14 haskell-aeson to version 2.0.3.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haskell-aeson package and not the haskell-aeson package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The aeson library is not safe to use to consume untrusted JSON input. A remote user could abuse this flaw to produce a hash collision in the underlying unordered-containers library by sending specially crafted JSON data, resulting in a denial of service.

CVSS Base Scores

version 3.1