Resource Exhaustion Affecting hivex package, versions <1.3.21-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.15% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-HIVEX-11745573
  • published10 Aug 2025
  • disclosed23 Dec 2021

Introduced: 23 Dec 2021

CVE-2021-3622  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:14 hivex to version 1.3.21-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hivex package and not the hivex package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in the hivex library. This flaw allows an attacker to input a specially crafted Windows Registry (hive) file, which would cause hivex to recursively call the _get_children() function, leading to a stack overflow. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1