CVE-2004-1182 Affecting hylafax package, versions <1:4.2.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.78% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-HYLAFAX-11745849
  • published10 Aug 2025
  • disclosed31 Dec 2004

Introduced: 31 Dec 2004

CVE-2004-1182  (opens in a new tab)

How to fix?

Upgrade Debian:14 hylafax to version 1:4.2.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hylafax package and not the hylafax package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

hfaxd in HylaFAX before 4.2.1, when installed with a "weak" hosts.hfaxd file, allows remote attackers to authenticate and bypass intended access restrictions via a crafted (1) username or (2) hostname that satisfies a regular expression that is matched against a hosts.hfaxd entry without a password.

CVSS Base Scores

version 3.1