OS Command Injection Affecting kconfig package, versions <5.54.0-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.07% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-KCONFIG-11747204
  • published10 Aug 2025
  • disclosed7 Aug 2019

Introduced: 7 Aug 2019

CVE-2019-14744  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:14 kconfig to version 5.54.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kconfig package and not the kconfig package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In KDE Frameworks KConfig before 5.61.0, malicious desktop files and configuration files lead to code execution with minimal user interaction. This relates to libKF5ConfigCore.so, and the mishandling of .desktop and .directory files, as demonstrated by a shell command on an Icon line in a .desktop file.

References

CVSS Base Scores

version 3.1