Improper Cross-boundary Removal of Sensitive Data Affecting kronosnet package, versions <1.35-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.08% (1st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-KRONOSNET-18300177
  • published25 Jul 2026
  • disclosed21 Jul 2026

Introduced: 21 Jul 2026

CVE-2026-15811  (opens in a new tab)
CWE-212  (opens in a new tab)

How to fix?

Upgrade Debian:14 kronosnet to version 1.35-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kronosnet package and not the kronosnet package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A vulnerability was found in kronosnet's (version <=1.34) cryptographic configuration management. The framework does not correctly zero-out or wipe sensitive memory segments after executing changes to its cryptographic configuration. This omission leaves raw encryption keys resident in memory after the associated structures are freed. A local attacker capable of leveraging memory disclosure techniques could exploit this flaw to retrieve the active encryption key, allowing them to decrypt cluster network communications or inject malicious packets to cause severe high-availability cluster instability.

CVSS Base Scores

version 3.1