NULL Pointer Dereference Affecting lasso package, versions <2.9.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LASSO-13842058
  • published6 Nov 2025
  • disclosed5 Nov 2025

Introduced: 5 Nov 2025

CVE-2025-46404  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Debian:14 lasso to version 2.9.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lasso package and not the lasso package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A denial of service vulnerability exists in the lasso_provider_verify_saml_signature functionality of Entr&#39;ouvert Lasso 2.5.1. A specially crafted SAML response can lead to a denial of service. An attacker can send a malformed SAML response to trigger this vulnerability.

CVSS Base Scores

version 3.1