Use of a Broken or Risky Cryptographic Algorithm Affecting libcrypto++ package, versions <8.6.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.16% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBCRYPTO-11747837
  • published10 Aug 2025
  • disclosed6 Sept 2021

Introduced: 6 Sep 2021

CVE-2021-40530  (opens in a new tab)
CWE-327  (opens in a new tab)

How to fix?

Upgrade Debian:14 libcrypto++ to version 8.6.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcrypto++ package and not the libcrypto++ package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The ElGamal implementation in Crypto++ through 8.5 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.

CVSS Base Scores

version 3.1