Improper Verification of Cryptographic Signature Affecting libdnf package, versions <0.55.2-6


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.12% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBDNF-11748060
  • published10 Aug 2025
  • disclosed19 May 2021

Introduced: 19 May 2021

CVE-2021-3445  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Debian:14 libdnf to version 0.55.2-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libdnf package and not the libdnf package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in libdnf's signature verification functionality in versions before 0.60.1. This flaw allows an attacker to achieve code execution if they can alter the header information of an RPM package and then trick a user or system into installing it. The highest risk of this vulnerability is to confidentiality, integrity, as well as system availability.

CVSS Base Scores

version 3.1