Information Exposure Affecting libebml package, versions <1.3.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.34% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBEBML-11748069
  • published10 Aug 2025
  • disclosed29 Jan 2016

Introduced: 29 Jan 2016

CVE-2015-8791  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:14 libebml to version 1.3.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libebml package and not the libebml package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The EbmlElement::ReadCodedSizeValue function in libEBML before 1.3.3 allows context-dependent attackers to obtain sensitive information from process heap memory via a crafted length value in an EBML id, which triggers an invalid memory access.